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Introduction

The use of Portable Document Formats (PDFs) has become increasingly popular for sharing information.  Unfortunately, persons with disabilities, who utilize screen readers or other assistive technologies to read the content of PDFs, cannot access the majority of PDFs posted online or created for printing purposes. To help ensure that 508 compliant PDFs are disseminated, this guide has been created to assist document publishers in converting scanned and non-scanned documents into accessible PDF.  
Tagged PDF
Similar to HTML tags, accessible PDF documents use tags to indicate the page elements that define the document’s content structure and how elements relate to one another.  These elements include headers, paragraphs, tables, graphics and list, to name a few.  PDFs that are tagged properly are not only accessible for assistive technology users, but can more easily be viewed on a variety of platforms and alternative devices such as, Black Berries and PDAs. In short, creating accessible PDFs dramatically increases information sharing.               
Figure 1:  Example of a tagged document
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PDF Tag Types
Most PDFs are comprised of a few basic tags that can be converted into 37 different tag types. Depending on the source of the tag, the tag’s name may appear differently in the PDF Tag Structure Tree.  To gain access to the Tags Structure Tree, from Adobe Acrobat’s main menu select View>Navigation Panels>Tags.  Once the Tags panel is displayed, press Shift 8 (*) to expand all tags.  Below is a list of the most commonly used tag types and tags that are created by Adobe Acrobat and Microsoft Office.   
	Tag Description
	Acrobat generated tag
	Microsoft Office generated tag

	Paragraph 
	<P>
	<Normal>

	Heading 1,2,3…
	<H1>,<H2>,<H3>…
	Heading 1, Heading 2, Heading 3….

	List
	<L>
	<L>

	Figure 
	<Figure>
	<Inline Shape>, <Inline Object> 

	Table
	<Table>
	<Table>

	Table Row
	<TR>
	<TR>

	Table Header Cell
	<TH>
	<TH>

	Table Data Cell
	<TD>
	<TD>

	Background (Not visible to screen readers)
	<Artifact>
	<Artifact>


Accessibility PDF Checklist

When creating an accessible PDF or when reviewing a PDF for 508 compliance, the following conditions must be considered.  The answers to all of the conditions should be Yes or NA (not applicable). If a No response is selected, the issue must be resolved before the document can be considered accessible. Each of these conditions can be tested by using a screen reader and running Adobe’s Accessibility Full Check tool located on Acrobat’s main menu under Advanced>Accessibility>Full Check.   
	Test Conditions 
	Yes/No/Na 

	 1.  Does the document contain actual text?  Scanned representations of 
text are not accessible.    
	

	 2.  Does the document’s content follow a logical reading order? 
	

	 3.  Are tabable elements placed in a logical tab order? 
	

	 4. Has the document been tagged and has a clear document structure been defined? 
	

	 5. Has alternative text been appropriately applied to all images, objects and form field elements?     
	

	 6.  Do data tables contain Column or Row header tags?  
	

	 7. Are elements that should be ignored by a screen reader tagged as artifacts?
	

	 8.  Has the document’s native language been defined?
	

	 9.  Are hyperlinks active and link to the appropriate destination? 
	

	10.  Are bookmarks labeled properly and do they link to the appropriate destination?
	


Creating an Accessible PDF 
Converting to PDF

There are two methods for converting a source document into a PDF.  Method A allows you to convert the document using Adobe Acrobat 9.0 tools.  Method B is recommended for converting Microsoft Office files into PDF, using the Adobe PDF plug-in located on the Office main menu bar.  

Method A:  Converting scanned and non-scanned documents into PDF using Adobe 9.0

When converting non Microsoft Office documents into PDF, open Acrobat and from the File menu select Create PDF.  After selecting the file location and type, click Open. The file will automatically convert into a PDF.  This method may generate a tagged or untagged PDF.  Untagged or poorly tagged PDFs are not accessible. Use Adobe’s Accessibility Full Checker and Read Out Loud tools to test the PDF for accessibility. Go to the Testing PDFs for Accessibility section to learn how to access these tools.  If the PDF is untagged, from Adobe Acrobat’s main menu select Advanced>Accessibility>Add Tags to Document to tag the PDF.    

Caution: Optical Character Recognition (OCR) must be performed on scanned documents before they can be tagged and made accessible.  Go to the Working with Scanned Documents section for more information. .    

Method B:  Converting files into PDF within Microsoft Office applications
1. Open the desired Office document source file.

2. From the Office applications menu bar, select Adobe PDF<Change Conversion Settings.  

Note: If the Adobe PDF menu item does not appear on the applications bar as shown below, the Adobe PDF plug-in has not been installed.  Convert the Office file using the instructions in method A.  
Figure 2:  Adobe Acrobat PDF Conversion tool   
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3. From the Settings tab, under Applications Settings check the following checkboxes.

· View Adobe PDF Results 

· Prompt for Adobe PDF File Name

· Convert Document information 

· Create Bookmarks
· Add links 

· Enable Accessibility and Reflow with tagged Adobe PDF

4. Select the Advanced Settings button.  Once the new window opens, change the Capability combo box selection to Acrobat 8.0(1.7).  This setting will ensure that the latest accessibility features are applied to the newly created PDF. 

5. Select OK to save conversion settings.  Once the settings have been saved, they will remain set unless changed by the user.

6. Select Adobe PDF<Convert to PDF from the Office applications menu to create a tagged PDF. When prompted, name the file and save it.  Once the conversion process is completed, Adobe 9.0 will launch and display the newly created PDF file.  
If the Office document was created using Formatting and Style elements, located on the Office toolbar, a well-tagged document will be generated.  In most cases, PDF files created using this method are 90% accessible.  To verify that the PDF is accessible, use Adobe’s Accessibility Full Checker and Read Out Loud tools to test the PDF.           
Testing PDFs for Accessibility
Before a PDF can be considered accessible, it must be properly tagged, have a logical reading and tab order, alternative text must be added to all images and objects and the document must have a specified language.  To verify that these key conditions are met, first run Adobe’s Accessibility Full Check and then listen to the PDF by running Adobe’s built-in screen reader Read Out Loud.    
Adobe Accessibility Full Check

To access Adobe’s Accessibility Full Check:

1. Select Advanced >Accessibility>Full Check
2. Select the Select All button to check all the check boxes.  This will ensure that the PDF is tested for full accessibility. 
3. Select Start Checking button.  
Figure 3: Accessibility Full Check Settings   
If the Accessibility Full Checker finds any errors, an Accessibility Report, that provides suggestions for repairing the document, will appear on the screen as shown below.  If additional help is needed, Press the F1 key to launch Adobe Help Viewer.    

Caution: The Accessibility Full Checker will not verify that the reading and tab orders are correct.  Use a screen reader to test the reading order and the Tab key to test the tab order.  

Figure 4:  Example of Adobe’s Accessibility Report 
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Adobe’s Read Out Loud Screen reader
To take advantage of Adobes built-in screen reader to test the PDF’s reading order:

1. From the View menu select Read Out Loud<Activate Read Out Loud.

2. Select View>Read Out Loud>Start.
If the document’s reading order is not correct, or has not been tagged correctly, the reading order and tags will need to be modified manually.  

Manually Adjusting PDF Tags 

If a document element was improperly tagged, the tag can quickly be converted to a more appropriate tag.  

1. Open the Tag Panel by selecting View>Navigation Panels>Tags from Acrobat’s main menu.    
2. Right click on the desired tag, and select Properties.  This will open the Touchup Properties window. 
Figure 5:  Example of Tags Properties menu
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3. From the Type combo box, select the correct tag and then close the window.  The updated tag will appear in the Tags tree.  
Figure 6:  Example of Touchup Properties window 
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If several document elements have been improperly tagged, it may be easier to delete all tags by highlighting the parent tag in the Tags Panel and pressing the Delete key.  Then use Acrobat’s Add Tags to Document tool to automatically tag the document or use the Touchup Reading Order tool to manually add tags to the document and establish the logical reading order.  To access the Touchup Reading Order tool:

1. From the Advanced menu select Accessibility>Touchup Reading Order.  The Touchup Reading Order tool will appear.   
2. Create a container around the first document element by holding down the left mouse button and drag the mouse across the first document element that needs to be tagged.  Headers, Figures, Tables, and Lists should all receive individual tags.  Depending on the logical reading order, Paragraphs may not need to receive individual tags.  

Figure 7:  Example of drawing a container and adding a tag to a document element.  
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3. Continue tagging the document until the entire document is tagged. 
The table below demonstrates the type of tags created by each button on the Touchup Reading Order tool.  Because this tool only creates a few basic tags, the Touchup Property tool will need to be used to create more detailed tags.     
	Touchup Reading Order Tool Buttons
	Tags Generated 

	Text Button:  Used for Paragraphs and List 
	<P>

	Form Field Button:  Used to indicate form field elements
	<Form>

	Heading 1 Button:  Used for the title of a document
	<H1>

	Heading 2, Heading 3 Buttons:  Used to indicate Sub-headings of a document
	<H2>, <H3>

	Figure Button:  Used to identify Images and Objects
	<Figure>

	Figure/Caption Button:  Used for figures with captions
	<Caption> 

	Table Button:  Used to identify Data Tables
	<Table>, <TR>, <TH>, <TD> 

	Cell Button:  Used to identify a Table Data Cell
	<TD>

	Formula Button:  Used for Equations in a document 
	<Formula>


4.  After tagging the document, adjust the reading order.  Go to the Manually Adjusting Reading Order sections fore more information.   

Manually Adjusting Reading Order 

The reading order determines the order a screen reader reads document elements.  In some cases the Physical View, which is the print view, and the Content View, which is the reading order are not the same.  Therefore, the reading order needs to be adjusted to match the Physical view.  To change the reading order:

1. From Acrobat’s main menu, select View>Navigation Panel>Order.  As shown below, once the Order Panel is displayed, numbers will appear on the document, revealing the document’s reading order.  
2. Identify the first element that is out of place and in the Order Panel click on the box to the left of the element and drag the element to the proper location. Continue this process until all elements are in the proper order.  

Figure 8:  Example of adjusting the document’s reading order        
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Adding Alternative Text

Alternative text is used to convey the purpose of images and objects embedded in documents.  Without alternative text, valuable information is lost, and the document may not be completely understood by users accessing the document with assistive technology and alternative devices.  To add alternative text to tagged elements:

1. Right click on the desired tag in the tags tree and select Properties. 

2. Go to the Alternative Text field located on the Touchup Properties window and add the appropriate alternative text. 

3. Close the window.  Once the document is saved, the alternative text will be applied.  

Figure 9:  Example of adding alternative text to a Figure tag 
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Setting the Document’s Language

Setting the proper document language enables screen readers to chouse the correct synthesizer for reading the document.  If the wrong synthesizer is chosen, the document will not read correctly.  To set the document’s language, from Acrobat’s main menu, select File>Properties and in the Language combo box, select the correct language.  Saving the document will apply all changes.  

Working With Scanned Documents

Working with scanned documents can be problematic because in most cases the documents are images and do not contain actual text.  To create a text content layer, Optical Character Recognition (OCR) must be performed.   

1. From Acrobat’s main menu select Document>OCR Text Recognition>Recognize Text using OCR.   

2. When the Text Recognition box appears, select Edit to modify the OCR settings. As shown below.  Make sure the correct document language is set, the PDF’s Out Put Style is set to Clear Scan and the Down sample images is set to at least 600 dpi.  

Figure 10:  Example of Recognize Text Settings
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3. Repair all OCR suspects by selecting Document>Recognize Text using OCR>Find First Suspects. 
4. The Find First Suspects  tool may not find all OCR suspects, therefore go to Tools>Advanced Editing and select Touchup Text Tool to repair textual OCR suspects and Touchup Object Tool to fix graphical OCR suspects.     

Once the process is complete, tag the document, adjust the reading order and test the document for accessibility.  After all necessary changes have been made, save the document.  
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